This looks horrible to me.
This looks wrong too:
And so does this:
And while we’re at it these two too, both of which require hand-indenting while fighting Xcode:
This is among the least bad:
What would you do to fix it?
Patrick Perini suggests:
Greg Titus thought using a simpler clause and a
Never-returning function might be better. Here’s some code where I incorporated his feedback: